DPARSF Time Points Error

Hello everyone!

I’m trying to run an analysis of functional data in DPARSF (basic edition, V2.1_120101) and I run into the following error: the program won’t run because the " Time Points " parameter is not correctly set.

I have 370 nifti files per subject, and this also checks out with the scanning parameters – in the file it clearly says “measurements: 370” and if I divide the scanning time by the TR, I get the same result, which is 370.

So after setting the " Time Points " parameter to 370, I get this message: “The detected time points of subject 001 is: 0, it is different from the predefined time points: 370”. I also tried setting it to 0, but then I get the message that I should set the number of time points of the functional data…

I have arranged the data as follows:


--- FunImg
--- --- T0CGV31 (370 nifti files)
--- --- T0CGV32 (370 nifti files)
--- --- T0CGV34 (370 nifti files)

--- T1Img
--- --- T0CGV31 (1 nifti file)
--- --- T0CGV32 (1 nifti file)
--- --- T0CGV34 (1 nifti file)

These are the files we get from the scanner - should the number of files in the functional subfolders match the number of the files in the structural subfolders?

Anyone has any idea how I could fix this?

Thank you,

Image icon DPARSF_error.png116.88 KB